nix-dotfiles/flake.nix
Thomas A. Christensen II 8cd4a1d582
build: Allow unfree packages
There's currently a bug in home-manager that does not allow for use of
unfreePredicate to specify which unfree packages are allowed in the
config. Use the workaround provided at
https://github.com/nix-community/home-manager/issues/2942#issuecomment-1378627909
to blanket allow unfree packages, instead.
2024-12-09 15:56:52 -06:00

43 lines
1.3 KiB
Nix

{
description = "Home Manager configuration of millironx";
inputs = {
# Specify the source of Home Manager and Nixpkgs.
nixpkgs.url = "github:nixos/nixpkgs/nixos-24.11";
nixpkgs-unstable.url = "github:nixos/nixpkgs/nixpkgs-unstable";
home-manager = {
url = "github:nix-community/home-manager/release-24.11";
inputs.nixpkgs.follows = "nixpkgs";
};
agenix = {
url = "github:ryantm/agenix";
inputs.nixpkgs.follows = "nixpkgs";
};
};
outputs = { nixpkgs, nixpkgs-unstable, home-manager, agenix, ... }:
let
system = "aarch64-darwin";
pkgs = import nixpkgs {
inherit system;
config.allowUnfree = true;
};
pkgs-unstable = import nixpkgs-unstable {
inherit system;
config.allowUnfree = true;
};
in {
homeConfigurations."millironx" =
home-manager.lib.homeManagerConfiguration {
inherit pkgs;
# Specify your home configuration modules here, for example,
# the path to your home.nix.
modules = [ ./home.nix agenix.homeManagerModules.default ];
# Optionally use extraSpecialArgs
# to pass through arguments to home.nix
extraSpecialArgs = { inherit pkgs-unstable; };
};
};
}